
 



Topics for Password Editor:

General Help
Create Password File
File Menu
Save File Configuration
Record Menu
Keys Help



General Help for Password Editor

Important:    Help is available at all times.    To access help from any dialog or field, simply press F1.    
Help for push buttons can be obtained by highlighting a button and pressing F1.

To exit the editor, select the Close option on the System menu.

What Is the Password Editor

This utility program creates SOFTERM.PWD, the file Softerm uses to provide the optional security feature
for Host Mode.

Note:    If there are no existing password files, use the Record menu's Add option to create an entry.    
Then use the File menu's Save As option to create the password file.

Important:    If Host Mode finds the SOFTERM.PWD file, security processing automatically is performed 
for each caller.    If you do not want any logon processing, ensure that SOFTERM.PWD does not exist.    
And remember, this can be a hidden file.

Security includes being able to limit the directories which can be accessed by each user and restricting 
the commands each user can use in Host Mode.    For additional information, please refer to the Host 
Mode and Script Files chapters in the documentation.

When a caller connects to your system and Host Mode finds the SOFTERM.PWD file, a logon sequence 
prompts the caller for a valid user name and password.

Primary Action Bar Menus

Use the File Menu to:

1. Open (load) an existing password file 
2. Save a password file using a current or a new name 
3. Configure how frequently changes will be saved 

Use the Record Menu to:

1. View and edit the individual entries in the displayed password file 
2. Add a new entry to the displayed password file 
3. Create an entry for a new password file
4. Delete an entry in the displayed password file 

Use the Help Menu to:

1. Learn about using the Help system 
2. Access this Help panel 
3. Learn about key functions within this program 
4. Access the Help Index 



Help

Use these choices to find out how to use help, to get general help, to go to a list of keys, to go to the help 
index, or to view product and copyright information. 

General help
Description of the Softerm Password Editor.

Keys help
Displays a list of keys.

Help index
Displays the help index.

Product information
Displays product and copyright information.
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Keys Help

For more information, select:

Cursor movement keys 
Action bar keys 
Menu keys 
Dialog keys 
System keys 



Help for Product Information

Select to display the copyright and product information.



Cancel

Exit this dialog without taking any action.



Close

Accept the displayed information and exit the dialog.



Help for File Menu

Use the File Menu to:

1. Open (load) an existing password file 
2. Save a password file using a current or a new name 
3. Configure how frequently changes will be saved 



Open

Use this File menu option to load an existing password file so it can be viewed and edited.    If a file 
already is loaded, it will be replaced by the new file.



Save As

Use this File menu option to save the displayed data to a new file name.

Note:    Save As is a good choice when major changes have been made or when you are 'cloning' a 
password file so it can be used on a different PC.



Save

Use this File menu option to save the displayed data to the current file name.



Save As

Save the displayed data to a new file name.

Note:    Save As is a good choice when major changes have been made or when you are 'cloning' a 
password file so it can be used on a different PC.



Configure

Select Configure to set how the Password Editor saves changes.    Changes can be saved as soon as 
they are made, or only when exiting this program.



Help for Save File Configuration

Set how often the Password Editor saves changes.

Save After Each Action
Check this System Integrity option if you want to save each change as soon as it is made.

Save On Exit Only
Check this option if you want to wait to save all changes until you exit the Password Editor.



Save After Each Action

Check this option if you want to save each change as soon as it is made.



Save On Exit Only

Check this option if you want to wait to save all changes until you exit the Password Editor.



Help for Record Menu

Use the Record Menu to:

1. View and edit the individual entries in the displayed password file 
2. Add a new entry to the displayed password file 
3. Create an entry for a new password file
4. Delete an entry in the displayed password file 

The View/Edit and Delete menu options are performed on the highlighted entry.



View/Edit

Use this Record menu option to examine and change the highlighted entry.    You also will be able to 
delete the entry.



Add

Use this Record menu option to create a new entry for the displayed password file.



Delete

Use this Record menu option to delete the highlighted entry.



Help for Open File

Use this dialog to open an existing password file.

Note:    The file must have the .PWD extension.

Important:    If there are no existing password files, use the Record menu's Add option to create an entry. 
Then use the File menu's Save As option to create the password file.

Open Filename
If you know the path and name of the password file, enter them here.    You also can use the Drive, File 
and Directory lists to locate the file.

Type of File
For this application, this field always will show only <Password file>.

Drive
Use this list to locate and select the appropriate disk drive.

File
Use this list to locate and select and existing file.    Important:    This list shows only existing files having 
the PWD extension.

Directory
Use this list to locate and select the appropriate disk directory.



File

Use this list to locate and select an existing file.    Important:    This list shows only existing files having 
the PWD extension.



File Hidden

If you want this file to have the hidden attribute, check this setting.



Type of File

For this application, this field always will show only <Password file>.



Directory

Use this list to locate and select the appropriate disk directory.



Drive

Use this list to locate and select the appropriate disk drive.



Open Filename

If you know the path and name of the password file, enter them here.    You also can use the Drive, File 
and Directory lists to locate and select the file.



Open

Select Open to load the displayed password file so that it can be viewed and edited.    If a file already is 
loaded, it will be replaced by the new file.



Help for Save As File

Use this dialog to save the displayed password file entries to a different file name.

Note:    The file must have the .PWD extension.

Save Filename
Enter the path and name to assign to the password file.    You also can use the Drive, File and Directory 
lists to set the path information.    The file must have a .PWD extension.

Type of File
For this application, this field always will show only <Password file>.

File Hidden
If you want this file to have the hidden attribute (meaning that a standard DIR command won't find it), 
check this setting.



Save Filename

Enter the path and name to assign to the password file.    You also can use the Drive, File and Directory 
lists to set the path information.

Important:    The file must have a .PWD extension.



Help for View/Edit/Delete

Use this dialog to:

1. Review the current information of an entry 
2. Change any of the information (Important:    The editing fields do not become active until you 

choose the Edit pushbutton.) 
3. Scan forward and back through the file's entries 

The dialog is divided into these three primary areas:

Control Group
These pushbuttons let you perform the following actions on the displayed data:

Edit
Change any of the displayed data.    When this button is selected, the editing fields become active.    The 
Control Group pushbuttons change to Save and Cancel.

Delete
Delete the displayed record.

Next
Display the next record in the password file.

Previous
Display the record before this one.

User Information
Displays and lets you edit the user's name, password and assigned directory.

User Rights
Displays and lets you edit the user's access restrictions.

For more information, select:

User Name
User Password
User Directory
Upload File
Download File
Delete File
Rename File
Change Directory
Issue Call
Issue Terminate



User Name

Enter or change the user's name.    This required field can contain a maximum of 32 characters.



User Password

Enter or change the user's Password.    This required field can contain a maximum of 16 characters.



User Directory

Enter or change the user's default directory.    This required field can contain a maximum of 64 characters.

This entry defaults to the directory in which PWDEDIT.EXE is located.



Upload File

Check this option if the caller is permitted to send a file to the host (this system).



Download File

Check this option if the caller is permitted to transfer a file from this system.



Delete File

Check this option if the caller is permitted to delete a file on this system.



Rename File

Check this option if the caller is permitted to rename a file on this system.



Change Directory

Check this option if the caller is permitted to change to another directory on this system.



Issue Call

Check this option if the caller is permitted to activate an interactive script file on this system.



Issue Terminate

Check this option if the caller is permitted to terminate Host Mode.



Help for Add User Record Entry

Use this dialog to add a new entry to the displayed password file or to create an entry for a file which does
not yet exitst.    (If so, use the File menu's Save As option to save the new entries to a file.)

Important:    All fields in the User Information area require entries before the Add pushbutton becomes 
active.

The dialog is divided into two primary areas:

User Information Area
Use to add the user's name, password and assigned directory.    These are required entries, and until all 
are filled-in, the Add pushbutton will not be active.

User Rights Area
Displays and lets you edit the user's access restrictions.

Dialog pushbuttons:

Close
Exit the dialog.    Displayed information is not saved.

Add
Add the displayed data to the password file.    Important:    All fields in the User Information area require 
entries before this pushbutton becomes active.

For more information, select:

User Name
User Password
User Directory



Add

Select this button to save the displayed data.



Edit

Select Edit to change any of the displayed data.    The editing fields will become active and the Control 
Group pushbuttons will change to Save and Cancel.



Save

Select this button to save the displayed data.



Delete

Select this button to delete this record.



Next

Select this button to display the next record in the password file.



Previous

Select this button to display the record before this one.



Cancel

Select this button to cancel the displayed data.



Help for Delete User Record

This dialog displays all the information in the record you have selected to delete from the password file.

Select Delete to remove this record, or select Cancel.



OK

Select OK to accept the dialog and continue.





Cursor Movement Keys

Use these keys to move the cursor in the editing area. 

Up
Moves the cursor up one line. 

Down
Moves the cursor down one line. 

Right
Moves the cursor right one character. 

Left
Moves the cursor left one character. 

Ctrl+Right
Moves the cursor to the beginning of the next word. 

Ctrl+Left
Moves the cursor to the beginning of the previous word. 

Home
Moves the cursor to the beginning of the current line. 

End
Moves the cursor to the end of the current line. 



Action Bar Keys

Use these keys to select the System icon and action bar items. 

F10
Switches between the action bar and the editing area. 

Shift+Esc
Switches between the System icon and the editing area. 

Right
Highlights the next action bar item or the System icon. 

Left
Highlights the previous action bar item or the System icon. 

Enter
Accesses the pull-down of the highlighted action bar item or System icon. 

Mnemonic
The mnemonic key is the key corresponding with the underlined letter in the action bar items.    It 
accesses the pull-down of the action bar item containing the mnemonic. 

Escape
Returns to the editing area. 



Menu Keys

Use these keys to select pull-down items. 

Up
Moves up one pull-down item. 

Down
Moves down one pull-down item. 

Enter
Selects the highlighted pull-down item. 

Mnemonic
The mnemonic key is the key corresponding with the underlined letter in the pull-down items.    It selects 
the pull-down item containing the mnemonic. 

Escape
Closes the pull-down. 



Dialog Keys

Use these keys to select dialog box items. 

Tab
Moves to the next control group on the dialog. 

Shift+Tab
Moves to the previous control group on the dialog.

Right
Moves to the next button on the dialog. 

Left
Moves to the previous button on the dialog. 

Up
Moves up one item in a selection box. 

Down
Moves down one item in a selection box. 

Page Up
Scrolls up one page in a selection box with scroll bars. 

Page Down
Scrolls down one page in a selection box with scroll bars. 

Spacebar
Switches a check box on and off.

Enter
Starts the activity for the selected pushbutton.

Escape
Exits the dialog.
    



System Keys

Use these keys to switch between, move, and size Presentation Manager windows. 

Alt+Tab
Switches to the next Presentation Manager window. 

Alt+Shift+Tab
Switches to the previous Presentation Manager window.

Alt+Esc
Switches to the next application (including non-Presentation Manager applications). 

Ctrl+Esc
Switches to the Task List. 

Alt+F4
Closes the active window. 

Alt+F5
Restores the active window. 

Alt+F7
Moves the active window. 

Alt+F8
Sizes the active window. 

Alt+F9
Minimizes the active window. 

Alt+F10
Maximizes the active window. 


